Page 1 of 1

AD AUTHENTICATION

Unread postPosted: Thu Mar 13, 2014 11:57 am
by sam-mayekawa
hello

I just installed de newest server version version 2.0.5.241.
I'm trying to authenticate users against the Active Directory but every time i try to login to the chat client, i will have an error that the username or password are incorrect:

ldap.png
ldap.png (9.35 KiB) Viewed 3838 times


This is my ldap.config.inc.php file:

Code: Select all
if ( !defined('INTRAMESSENGER') ) die();

$ldap_host = "10.1.1.1";
$ldap_port = "389";
$ldap_basedn = "cn=Users,o=mycomeurope, c=local";


Is there any way to solve this problem?

Re: AD AUTHENTICATION

Unread postPosted: Fri Mar 14, 2014 11:00 am
by THeUDS
Does PHP Extensions "php_ldap" is enabled ?

Re: AD AUTHENTICATION

Unread postPosted: Mon Mar 17, 2014 9:47 am
by sam-mayekawa
Yes, i have a Wordpress site on the same server with working AD authentication.

Re: AD AUTHENTICATION

Unread postPosted: Wed Mar 26, 2014 4:05 pm
by sam-mayekawa
Can someone help me with this please?
The server has to go online next week.

Re: AD AUTHENTICATION

Unread postPosted: Wed Mar 26, 2014 6:48 pm
by THeUDS
Can you try test.php from this test module ?


If users are on Windows domain,
note that you can force nickanme to Windows username (%USERNAME%)
and disable password with options:
_FORCE_USERNAME_TO_PC_SESSION_NAME
_USER_NEED_PASSWORD

Re: AD AUTHENTICATION

Unread postPosted: Thu Mar 27, 2014 2:41 pm
by sam-mayekawa
I've changed
Code: Select all
cn=Users,o=mycomeurope, c=local

to
Code: Select all
cn=Users,dc=mycomeurope,dc=local

And that works in the test.php file. I get the message "OK".

The option _FORCE_USERNAME_TO_PC_SESSION_NAME is cheked, but i can't disable the option _USER_NEED_PASSWORD.
I get this message:

1 option(s) were automatically corrected
USER_NEED_PASSWORD


There is also another message on the ACP:
External authentication Activated: check configuration for options: _EXTERN_URL_TO_REGISTER.
.

And it is still not possible to sing on trough AD from the client...

Re: AD AUTHENTICATION

Unread postPosted: Thu Mar 27, 2014 6:18 pm
by THeUDS
sam-mayekawa wrote:I've changed
Code: Select all
cn=Users,o=mycomeurope, c=local

to
Code: Select all
cn=Users,dc=mycomeurope,dc=local

And that works in the test.php file. I get the message "OK".

Do you try in your options file to ?

Re: AD AUTHENTICATION

Unread postPosted: Thu Mar 27, 2014 6:20 pm
by THeUDS
sam-mayekawa wrote:The option _FORCE_USERNAME_TO_PC_SESSION_NAME is cheked, but i can't disable the option _USER_NEED_PASSWORD.
I get this message:

1 option(s) were automatically corrected
USER_NEED_PASSWORD


You must disable external authentication (select empty in drop down list) to disable USER_NEED_PASSWORD.


There is also another message on the ACP:
External authentication Activated: check configuration for options: _EXTERN_URL_TO_REGISTER.
.
Don't care about it,
it's for forum, CMS...